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Active Excel: Fun Projects and Games

Excel can be incorporated in many different subject areas and grade levels. Students
can use it independently or as a class when the instructor projects a spreadsheet.
Excel works well with small group projects, and can also be used by students
individually for quiet work. Following are some sample projects and activities that use
Excel in the classroom.

Interactive Crossword Puzzle

Use the comment feature to add clues in beginning letter cell for each word. Use color
or borders to distinguish cells in which to add letters.

Tutorial from Microsoft: http://www.microsoft.com/education/Crossword.mspx

Countdown to an Important Date!

1) Type date you are counting down to in cell A1, for example: 6/1/07

2) Type this formula in cell A2: =TODAY()

3) Type this formula in cell A3: =A1-A2

4) With cell A3 selected, go to Format - Cells, then click the Number tab. Change the
number format to Number and choose 0 for decimal places.

Following Directions

Call out color and cell addresses. Students use the paint bucket to fill the cells with a
color. Use the colors/cells to spell out words or designs.

Mazes

To teach students more about formatting cells, you can have them create mazes. Make
the cell width the same as the cell height. Use cell borders to draw the solid lines,
leaving some “open” to make the path through the Maze. Four colored cells in the
center can serve as a destination.

Microsoft Lesson Plans for Students and Educators

http://www.microsoft.com/education/lessonplans.mspx
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Lonely Bingo

This exercise allows a student to play a Bingo game alone by interacting with an Excel
spreadsheet. The techniques described could also be used for other interactive
worksheet formats if the idea of Bingo does not appeal. This activity uses: cell size
formatting, comments and conditional formatting.

1) Format the columns and rows so that you have a five by five game board of squares.
Size the cells to accommodate your longest word(s), or format the columns to wrap text.
Make the cells large enough to hold at least one word without splitting it.

2) Using the 25 questions you created, enter them as comments:
» Click on the cell in which you wish to enter a question.
* Go to the Insert menu > Comment.
» Type your comment in the yellow “sticky” box that pops up.
* To hide comments, go to the View menu - Comments.
*  When comments are hidden, you can mouse over a cell and the comment will
pop up.
* To see all comments displayed again, go to the View menu - Comments and it
will toggle the display on.
Repeat the insert comments steps for each cell until you have entered all 25 questions.

3) Enter answer information.
» Select a cell for which to enter the answer.
* Go to the Format menu - Conditional Formatting.
* From the drop down menu in the middle, choose “equal to”
» Enter the correct answer text in the field on the right.
» Click the Format button = Patterns tab, then choose a color.
* Click OK.
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5) To Play: Provide student with a COPY of the spreadsheet file. Student floats the
mouse over a cell to read the question, then types their answer in the cell. When they
answer correctly, the cell color appears. They “win” by getting five cells in a row
colored.



Excel Bingo Boards

1) Refer to this web site from Jeff and Heather Ertzberger to access the templates you
will need to create the Bingo Boards:

http://people.uncw.edu/ertzbergerj/excel_games.html

* Download 3x3 or 5x5 Bingo board template. Note that this template uses a
Macro, which may cause a security alert.

* In the downloaded file, you will need to enter your words in each cell in the
board. Then, click the “shuffle” button, then print the card. Then, click shuffle
and print another card, etc. until you have all the cards you wish.

2) Here’s an alternative Bingo Board from Jefferson County Schools in Tennessee.
(http://www.jc-schools.net).

http://www.jc-schools.net/tutorials/vocab/STUDY_BINGO.xIs

» This spreadsheet is ready to go. Download it and type in 30 vocabulary terms of
your choice.

» Print the sheet to get a total of 32 different cards.

* To “play”, read your definitions and have students mark the words they find on
their printed cards.



Create a “Self Test”

You will need:
» Short questions, short answers
* Optional list of words for matching
* Indicator of right or wrong answer
* The “IF” function

Layout:
* Heading with directions

* Sub-heading with optional list of words from which to choose

* OR, additional column with list of words from which to choose

* First column for question

» Second column for answer

* Third column contains “IF” function to indicate if the answer is right or wrong

Example: Test your planetary knowledge
Enter the name of the celestial body that corresponds with each fact.
Choose from the following: Sun, Moon, Jupiter, Saturn, Pluto, Mercury, Mars, Venus

All planets rotate around me. =|F(A3="Sun","YES","NQO")
| have five moons. =|F(A4="Jupiter","YES","NQO")
| am the most recently discovered planet. =IF(A5="Pluto","YES","NQO")
| am the closest to the sun. =|F(A6="Mercury","YES","NO")
| am a gaseous planet. =|IF(A7="Venus","YES","NQO")
Explanation:
Note the following components of the “IF” function:
o =IF(

All formulas or functions begin with an equal sign. IF indicates the function to be
performed. The parenthesis enclose the “variables” to be considered.

e A3=
This gives the cell address whose content is to be compared.

s “Sun’,
This is the value with which to compare the cell content. It must be in “quotation” marks
if itis text. Note that ALL text must be in quotation marks. Also, if a student typed “sun”
with a lowercase S, there would not be a match. CASE MATTERS when text is in
quotation marks. The commas separates the comparison value from the next value.

e “YES”,
This is the value which is shown in the cell where you type the “IF” function, IF A3 does
equal “Sun”. Again, quotation marks are necessary to indicate text. The comma
separates this value from the last.

« “‘NO”
The final value in the function is the value which appears IF A3 does not equal the value
given immediately following the equal sign.




Battleship Game
To teach concepts of slope, or points on a graph, pair students with a laptop and have
them create and then play a “battleship” game.

To create the battleship game, you will primarily use formatting features. Each
workbook should contain two formatted worksheets — one for the player’s own ships,

and one in which to mark hits on the “enemy’s” ships.

Rename Sheets
1) Click the Sheet1 tab at the bottom of your spreadsheet window. Right click to get the
pop-up menu, then choose rename. Type the new name in the tab.

2) You can also double-click the sheet tab and type in the new name. Call the first
sheet Enemy Ships.

3) Click or double click Sheet2 tab and rename Sheet2 My Ships.
4) Return to the “Enemy Ships” tab to begin formatting the first game board.

Set up Game Board
1) Adjust column width and row height to create larger, square cells.

a) Put your cursor over the column label A, and drag over to column J. You should
have columns A — J highlighted.

b) With your cursor still in the grey column heading area, position it over the
boundary line between two column headings. The cursor should look like a double-
headed arrow. Click and drag the cursor to change the column width. As you drag,
a yellow “sticky” label appears. Use that as a guide to set the width to 50 pixels (or
eyeball the size). When you release from dragging, all 10 columns should be the
same narrower size.

c) Position your cursor over the row one heading number one. Drag down until 10
rows are highlighted. With your cursor still in the grey row heading area, position it
over the boundary between two of the rows so it looks like a double headed arrow.
Drag the boundary down until the yellow “sticky” indicates 50 pixels (or eyeball the
size).

2) Color the cells of the 10x10 grid and display all cell borders.

a) Highlight the range A1:J10. This should create a square 10 columns wide by 10
rows deep.

b) Using the paint bucket button on your formatting toolbar (far right), choose a light
blue color to fill the highlighted area.

c) After setting a fill color, the gridlines disappear. While the game board area is still
selected, use the borders button next to the paint bucket on the formatting toolbar
and choose the selection for All Borders.



3) Format cell alignment so text is centered vertically and horizontally in all game board
cells.

a) With the range A1:J10 still selected, go to the Format menu - Cells - Alignment
tab. Choose “center” for the horizontal and vertical cell alignment.

4) Copy game board to second worksheet My Ships.

a) With the range A1:J10 selected, choose copy. Click the tab for My Ships at the
bottom of the workbook screen.

b) In the new worksheet, choose paste. This pastes the color, but you need to
repeat step 1 from above to change the column and row sizes.

SAVE THE WORKSHEET.

You may position ships, or students can enter their ships’ positions. Use the following
key for number and size of ships.

Number of Ships Ship Length Color
1 Aircraft Carrier 6 squares Orange
2 Battleships 5 squares Yellow
2 Destroyers 4 squares Light green
2 Submarines 3 squares Grey
1 Cruiser 2 squares Light Red
Color Ships

1) Select the “squares” or cells where the ship should be located. Use the paint bucket
on the formatting toolbar to change the fill color of those ships. Note that the ships are
entered only in the My Ships worksheet.

SAVE THE WORKSHEET.

Playing the Game

1) Two students play together, and use laptops or turn the monitors so they can not see
each others’ screens.

2) Decide who goes first.

3) That player calls out the column and row —i.e. “C5”.

4) The opponent answers hit or miss.

5) On the sheet Enemy Ships (NOT where your ships are!), the player marks an H for
hit, an M for miss, or an HS for hit and sunk (or color the cells of the sunk ship black). If
you get a hit, you get a second guess.

6) Now the opponent gets to call out a column and row. The player looks at the My
Ships sheet and marks an H or an M, depending on if a ship is hit or not.

The first player to sink all of the opponents’ ships is the winner.



Mastermind Game

You will need:
A four digit code, composed of numbers between 1 and 10 - fewer number choices for
younger students or faster play.

Layout:
Create a sheet that uses 9 columns. The first column should be numbered to represent

the number of “tries” at breaking the code. The second — fifth columns are where
students will enter their “codes”. The sixth — ninth columns are where you enter “IF”
statements, and students see an “X” to indicate they have a correct number.

Use color to indicate the cells in which students will type, and use lines, borders or color
over the cells where you enter the formulas to indicate if student’s number is correct.

Example:
Students use numbers 1 — 6. My “code”is: 3, 5, 2, 1.

The first row of the game in my sheet looks like this:

A|B|C|D]E F G H I

2 =IF(B3=3,"X"," ") =IF(C3=5,"X""") =IF(D3=2,"X""") =IF(E3=1,"X""")

» To save time, enter the formula in cell F2 first.

* Use the Fill Handle to drag the formula ACROSS G, H and I.

» EDIT the formula in each cell so that the “=value” matches your correct code.

» Select all four cells and use the fill handle to drag down as many rows as you will
allow students attempts to break the code. (Using six possible digits, a student
could easily break the code in 6 tries.) It is not necessary to edit the formulas
after you drag them down, since the “correct” value does not change.

* For more information on the components of the IF statement, refer to the “self-
test” example provided on another page.

It would be best to “protect” the sheet, allowing students to view or type in the cells in
columns B — E only. To do this, there are two parts:

1) Format the cells

a) Select the cells in which students will type their answers.

b) Go to the Format menu - Cells - Protection tab.

c) Click the check box for “locked”, so that the selected cells are NOT locked.
2) Protect the sheet

a) Go to the Tools Menu - Protection - Protect Sheet.

b) Add a password if desired, so students can not easily “unprotect” the sheet.
c) Under “Allow all users of this worksheet to”, click the checkbox next to “Select locked
cells”, so that the only item with a checkmark in it is “Select unlocked cells”.



Standard Conversions

Excel can be used to practice standard conversions, or to make a reference table for
common conversions. In this example, use the standard formula for converting
Centigrade to Fahrenheit — a tricky formula to calculate in your head. Other examples
might include Miles per hour to Kilometers per hour, inches or feet to centimeters or
meters, miles to feet, etc. You might also consider making a table for a common cookie
recipe: if you want half as many cookies, or twice as many as the standard recipe
makes, students can convert the original cups and tablespoons to make the desired
amount.

This is the formula to convert Centigrade to Fahrenheit:
9/5 x Centigrade + 32 = Fahrenheit
Using this formula, create an Excel spreadsheet that shows the Fahrenheit equivalent of
all the centigrade degrees from 5-35. Think carefully how you can use the fill handle to
improve your efficiency. Once designed, how fast can you create the table?
One method to try:
In column A, enter the values you wish to convert. In our example, we want equivalent
Fahrenheit degrees for the range of 5 to 35 degrees Centigrade. Enter 5 in the second
row, and 6 in the third row. Click the fill handle and drag until you see 35 entered in the
cell.
In row two of column B, enter your formula, but substitute the cell address A2 for the
actual degrees Centigrade which are already listed in column A. The formula looks like
this:

=9/5*A2+32

Using the fill handle, drag the formula down column B until you reach 35 in column A.

How would you make a similar table to convert Fahrenheit to Centigrade?

Spreadsheet Safari
This web site has several Excel activities with instructions available in Excel or PDF
format. One such sheet includes many common conversions:

http://library.thinkquest.org/J0110054/Conversion.html



